Downgrade TeamSpeak to 3.0.18.2

As the SinusBot is not yet compatible with TeamSpeak Client 3.1+, you might want to downgrade if you upgraded to 3.1 by accident.

  • (backup the data directory of your SinusBot installation)
  • delete the TeamSpeak 3 Client folder of your SinusBot installation
  • delete the data/ts3 folder of your SinusBot installation (only the ts3 subdirectory!)
  • uninstall TeamSpeak Client
  • download an older version of TeamSpeak (>= 3.0.9, < 3.1) and install it
  • re-install the SinusBot

No data should be lost this way.

  • delete the TeamSpeak 3 Client folder of your SinusBot installation
  • delete the data/ts3 folder of your SinusBot installation (only the ts3 subdirectory!)
  • download an older version of TeamSpeak (or use the installer script)
  • run chmod +x TeamSpeak3-Client-linux_amd64-3.0.18.2.run and ./TeamSpeak3-Client-linux_amd64-3.0.18.2.run
  • copy the plugin again using cp plugin/libsoundbot_plugin.so /opt/sinusbot/TeamSpeak3-Client-linux_amd64/plugins

No data should be lost this way.

If the ts client is still not able to connect it might be the case that the server requires a newer client version, you can change this by using the following commands in the server query:

login serveradmin <password>
use sid=1
serveredit virtualserver_min_client_version=1445512488